Thursday 17 May 2012

VTP Configuration part 1

                              VTP Configuration part 1



1.      Take 3 Switches.
2.      Connect 3 switches through cross over.
3.     Configure the VTP in switch0.
        Switch>
                   Switch>enable
                   Switch#config t
                   Enter configuration commands, one per line.  End with CNTL/Z.
                   Switch(config)#int fastethernet fa0/1
                   Switch(config-if)#switchport mode trunk
                   Switch(config-if)#description uplink-to-switch0
                   Switch(config)#int fastethernet fa0/1
                   Switch(config-if)#switchport mode trunk
                   Switch(config-if)#description uplink-to-switch0    
                   Switch(config-if)#exit
                   Switch(config)#int vlan 1
                   Switch(config-if)#ip address 192.168.1.1 255.255.255.0
                   Switch(config-if)#exit
                   Switch(config)#exit
                   Switch# 
                   Switch#sh ip interface brief
                   Switch#config t
                   Enter configuration commands, one per line.  End with CNTL/Z.
                   Switch(config)#
                   Switch(config)#vtp domain CCNALAB
                   Changing VTP domain name from NULL to CCNALAB
                    Switch(config)#
                    Switch(config)#exit
                    Switch#
                    Switch#sh vtp status
                                  
                     Switch#config t
                     Enter configuration commands, one per line.  End with CNTL/Z.
                     Switch(config)#vlan 10
                     Switch(config-vlan)#name Accounts
                     Switch(config-vlan)#exit
                     Switch(config)#vlan 20
                     Switch(config-vlan)#name Sales
                     Switch(config-vlan)#exit
                     Switch(config)#vlan 30
                     Switch(config-vlan)#name Hr
                     Switch(config-vlan)#exit
                     Switch(config)#exit
                     Switch#
                               
                       
4.      Configuration on another switches.(Switch1)
        
                     Switch>enable
                     Switch#sh vtp status

            

                     Switch(config)#int fastethernet 0/1
                     Switch(config-if)#switchport mode trunk
                     Switch(config-if)#description uplink-to-switch0
                     Switch(config-if)#exit
                     Switch(config)#vtp mode client
                     Setting device to VTP CLIENT mode.
                     Switch(config)#exit

                     %SYS-5-CONFIG_I: Configured from console by console
                      Switch#sh vtp status

                     

                       Switch#config t
                       Enter configuration commands, one per line.  End with CNTL/Z.
                       Switch(config)#int fastethernet 0/8
                       Switch(config-if)#switchport mode access
                       Switch(config-if)#switchport access vlan 10
                       Switch(config-if)#exit
                       Switch(config)#exit
                       Switch#

5.           Configuration on another switches.(Switch2)
                      
                      Switch>enable
                      Switch#config t
                      Enter configuration commands, one per line.  End with CNTL/Z.
                      Switch(config)#int fastethernet 0/2
                      Switch(config-if)#switchport mode trunk
                      Switch(config-if)#description uplink-to-switch0
                      Switch(config-if)#exit
                      Switch(config)#exit
                      Switch# 
                      Switch#config t
                      Enter configuration commands, one per line.  End with CNTL/Z.
                      Switch(config)#int fastethernet 0/4
                      Switch(config-if)#switchport mode access
                      Switch(config-if)#switchport access vlan 10
                      Switch(config-if)#exit
                      Switch(config)#exit
                      Switch#
6.      Connect 2 Pc to switch 2 and assign ip address as (PC2 ip address 192.168.10.12  255.255.255.0) (PC3 ip address 192.168.1.13 255.255.255.0)
7.      Connect 3 Pc to switch 1 and assign ip address as (PC1 ip address 192.168.1.11 255.255.255.0) (PC4 ip address 192.168.10.13 255.255.255.0) (PC0 ip address 192.168.1.10 255.255.255.0)
8.      No ping from PC2 to PC4.


               If is there any mistakes and for any clarification please mail to 
                                                    ccnalab06@gmail.com 


     

Monday 14 May 2012

Basic Vlans and Trunks Part 4


 Basic Vlans and Trunks Part 4


1.      Take 3 Switches.
2.      Connect 3 switches through cross over.
3.     Configure the Hostname as well as the Vlans.
        Switch>
                   Switch>enable
                   Switch#hostname
                  Translating "hostname"...domain server (255.255.255.255)
                  % Unknown command or computer name, or unable to find computer address

                  Switch#config t
                  Enter configuration commands, one per line.  End with CNTL/Z.
                  Switch(config)#hostname CCNA
                  CCNA(config)#vlan 99
                   CCNA(config-vlan)#name Admin
                   CCNA(config-vlan)#exit
                  CCNA(config)#vlan 10
                  CCNA(config-vlan)#name MLAB
                  CCNA(config-vlan)#exit
                   CCNA(config)#vlan 20
                   CCNA(config-vlan)#name ALAB
                   CCNA(config-vlan)#exit
                   CCNA(config)#vlan 30
                   CCNA(config-vlan)#name ELAB
                   CCNA(config-vlan)#exit
                   CCNA(config)#exit
                   CCNA# copy running-config startup-config
                   Destination filename [startup-config]?
                   Building configuration...
                   [OK]
                   CCNA#

4.      Same configuration on another switches.
5.      Take 7 systems and rename as the following figure.
6.       Using the Config tab in Packet Tracer, configure the IP address, mask, and default gateway on each host
 PC – 192.168.10.100 255.255.255.0
 PC – 192.168.10.101 255.255.255.0

PC – 192.168.20.100 255.255.255.0
PC – 192.168.20.101 255.255.255.0

PC – 192.168.30.100 255.255.255.0
PC – 192.168.30.101 255.255.255.0

Admin System 192.168.99.100 255.255.255.0

7.      Configure the Vlans on switch0(CCNA)
               CCNA2#config t
                Enter configuration commands, one per line.  End with CNTL/Z.
                CCNA2(config)#int range fa0/6-10
                CCNA2(config-if-range)#switchport mode access
                 CCNA2(config-if-range)#switchport access vlan 10
                 CCNA2(config-if-range)#exit
                 CCNA2(config)#int range fa0/11-17
                 CCNA2(config-if-range)#switchport mode access
                 CCNA2(config-if-range)#switchport access vlan 20
                 CCNA2(config-if-range)#exit
                 CCNA2(config)#int range fa0/18-23
                 CCNA2(config-if-range)#switchport mode access
                 CCNA2(config-if-range)#switchport access vlan 30
                 CCNA2(config-if-range)#exit
                 CCNA2(config)#int fa0/24
                  CCNA2(config-if)#switchport mode access
                  CCNA2(config-if)#switchport access vlan 99
                   CCNA2(config-if)#exit
                   CCNA2(config)#exit
8.      Same configuration on another switches    
9.      Configure the trunk
Switch CCNA
                  CCNA>enable
                   CCNA#config t
                   Enter configuration commands, one per line.  End with CNTL/Z.
                    CCNA(config)#int range fa0/1-2
                     CCNA(config-if-range)#switchport mode trunk

                  %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to 
                   down

                 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up


                  %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to 
                    down

                 %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up

                CCNA(config-if-range)#switchport trunk native vlan 99
              CCNA(config-if-range)#exit
            
                   CCNA(config-if)#exit
                   CCNA(config)#exit
              Switch CCNA1
                     CCNA1#config t
                    Enter configuration commands, one per line.  End with CNTL/Z.
                     CCNA1(config)#int fa0/1
                     CCNA1(config-if)#switchport mode trunk
                      CCNA1(config-if)#switchport mode
                      %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on 
                       FastEthernet0/1                        
                      (1), with CCNA FastEthernet0/1 (99).

                        % Incomplete command.
                       CCNA1(config-if)#switchport trunk native vlan 99
                       CCNA1(config-if)#exit
                       CCNA1(config)#exit
                    Switch CCNA2
                     CCNA2#config t
                      Enter configuration commands, one per line.  End with CNTL/Z.
                     CCNA2(config)#int fa0/1
                     CCNA2(config-if)#switchport mode trunk
                      CCNA2(config-if)#switchport mode
                      %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on     
                       FastEthernet0/1                        
                      (1), with CCNA FastEthernet0/1 (99).

                        % Incomplete command.
                       CCNA2(config-if)#switchport trunk native vlan 99
                       CCNA2(config-if)#exit
                       CCNA2(config)#exit

                      Now try to ping from PC 192.168.10.100 to 192.168.10.101.

                               If is there any mistakes and for any clarification please mail to  
                                                    ccnalab06@gmail.com



     

Wednesday 9 May 2012

Basic Vlans and Trunks Part 3


 Basic Vlans and Trunks Part 3

1.      Take 2 Switches.
2.      Connect 2 switches through cross over cable from Fastethernet 0/1 to Fastethernet 0/1.
3.     Configure the Hostname as well as the management LAN settings.
Switch>Enable
Switch#Config t
Switch(config)#hostname CCNA_1
CCNA_1(config)#interface VLAN 1
CCNA_1(config-if)#ip address 192.168.1.1 255.255.255.0
CCNA_1(config-if)#no shut

CCNA_1(config)#
ip default-gateway 192.168.1.254
Switch>Enable
Switch#Config t
Switch(config)#hostname CCNA_2
CCNA_2(config)#interface VLAN 1
CCNA_2(config-if)#ip address 192.168.1.2 255.255.255.0
CCNA_2(config-if)#no shut

CCNA
_2(config)#ip default-gateway 192.168.1.254.
4.      Take 6 systems and rename as M1,M2,A1,A2,E1 and E2 as in the figure.
5.       Using the Config tab in Packet Tracer, configure the IP address, mask, and default gateway on each host
A1 – 192.168.10.1 255.255.255.0 with a default gateway of 192.168.10.254
A2 – 192.168.10.2 255.255.255.0 with a default gateway of 192.168.10.254

M1 – 192.168.20.1 255.255.255.0 with a default gateway of 192.168.20.254
M2 – 192.168.20.2 255.255.255.0 with a default gateway of 192.168.20.254

E1 – 192.168.30.1 255.255.255.0 with a default gateway of 192.168.30.254
E2 – 192.168.30.2 255.255.255.0 with a default gateway of 192.168.30.254

6.      Configure the Vlans on switch0(CCNA_1)
       CCNA_1#config t
   CCNA_1(config)#vlan 10
   CCNA_1(config-vlan)#name M1
   CCNA_1(config-nlan)#exit
   CCNA_1(config)#
   CCNA_1(config)#vlan 20
   CCNA_1(config-vlan)#name A1
   CCNA_1(config-nlan)#exit
   CCNA_1(config)#
   CCNA_1(config)#vlan 30
   CCNA_1(config-vlan)#name E1
   CCNA_1(config-nlan)#exit
   CCNA_1(config)#exit
   CCNA_1#
7.      Configure the Vlans on switch1(CCNA_2)
   CCNA_2#config t
   CCNA_2(config)#vlan 10
   CCNA_2(config-vlan)#name M1
   CCNA_2(config-nlan)#exit
   CCNA_2(config)#
   CCNA_2(config)#vlan 20
   CCNA_2(config-vlan)#name A1
   CCNA_2(config-nlan)#exit
   CCNA_2(config)#
   CCNA_2(config)#vlan 30
   CCNA_2(config-vlan)#name E1
   CCNA_2(config-nlan)#exit
   CCNA_2(config)#exit
   CCNA_2#
8.      Assign ports to VLAN
     CCNA_1#configure terminal
      CCNA_1(config)#interface fastethernet 0/2
      CCNA_1(config-if)#switchport mode access
CCNA_1(config-if)#switchport access vlan 10
 
CCNA_1#configure terminal
      CCNA_1(config)#interface fastethernet 0/3
CCNA_1(config-if)#switchport mode access
CCNA_1(config-if)#switchport access vlan 20

CCNA_1#configure terminal
      CCNA_1(config)#interface fastethernet 0/4
CCNA_1(config-if)#switchport mode access
CCNA_1(config-if)#switchport access vlan 30

          Another switch CCNA_2
           CCNA_2#configure terminal
      CCNA_2(config)#interface fastethernet 0/2
CCNA_2(config-if)#switchport mode access
CCNA_2(config-if)#switchport access vlan 10

CCNA_2#configure terminal
      CCNA_2(config)#interface fastethernet 0/3
CCNA_2(config-if)#switchport mode access
CCNA_2(config-if)#switchport access vlan 20

CCNA_2#configure terminal
      CCNA_2(config)#interface fastethernet 0/4
CCNA_2(config-if)#switchport mode access
CCNA_2(config-if)#switchport access vlan 30
 
9.      Configure the trunk
             CCNA_1(config)#interface fastethernet 0/1
                  CCNA_1(config-if)#switchport mode trunk
                  CCNA_1(config-if)#end
                  CCNA_2(config)#interface fastethernet 0/1  
                   CCNA_2(config)#switchport mode trunk
                  CCNA_2(config)#end

10.   Test the VLANs and the Trunk

                  Ping from the E1 host to the E2 host The ping should be successful.

     

     If is there any mistakes and for any clarification please mail to ccnalab06@gmail.com (zerosix)



     

Tuesday 8 May 2012

Basic Vlans and Trunks Part 2


 Basic Vlans and Trunks Part 2

1.      Take 12 systems.                                 
2.      Change top three systems name and IP Address as
 (Morning Lab F 192.168.1.97    Afternoon Lab F 192.168.1.98   Evening Lab F 192.168.1.99)
3.      Change left three systems name and IP Address as
 (Morning Lab1  192.168.1.27    Morning Lab2  192.168.1.28   Morning Lab3  192.168.1.29)
4.      Change Down three systems name and IP Address as
 (Afternoon Lab1  192.168.1.37    Afternoon Lab2  192.168.1.38   Afternoon Lab3  192.168.1.39)
5.      Change left three systems name and IP Address as
 (Evening Lab1  192.168.1.47    Evening Lab2  192.168.1.48   Evening Lab3  192.168.1.49)
6.      Take  One switch2960 and configure as shown below.
       Single click on switch and select CLI (IOS command line interface)
       Switch>
       Switch>enable
       Switch#config t
             Enter configuration commands, one per line.  End with CNTL/Z.
      Switch(config)#hostname CCNA
      CCNA(config)#vlan 10
      CCNA(config-vlan)#name LabF
      CCNA(config-vlan)# vlan 20
     CCNA(config-vlan)#name MorningLab
     CCNA(config-vlan)# vlan 30
     CCNA(config-vlan)#name AfternoonLab
     CCNA(config-vlan)# vlan 40
     CCNA(config-vlan)#name EveningLab
     CCNA(config-vlan)#exit
     CCNA(config)#exit
     CCNA#
       Now we will check vlans
      CCNA# show  vlan
        Now we will access switrchport to vlan
     CCNA#
     CCNA# config t
             Enter configuration commands, one per line.  End with CNTL/Z.
     CCNA(config)#interface fastethernet 0/1
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 20
     CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/2
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 30
     CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/3
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 40
     CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/4
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 20
     CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/5
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 20
      CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/6
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 20
      CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/7
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 30
     CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/8
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 30
     CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/9
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 30
     CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/10
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 40
     CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/11
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 40
     CCNA(config-if)#exit
      CCNA(config)#interface fastethernet 0/12
     CCNA(config-if)#switchport mode access
     CCNA(config-if)#switchport access vlan 40
     CCNA(config-if)#end
     CCNA#show vlan
       

  Now try to ping from one Morning Lab F(192.168.1.97) to Morning Lab 1(192.168.1.27)
   It will replay.
  Now try to ping from one Morning Lab 1(192.168.1.97) to Morning Lab 3(192.168.1.29)
   It will replay.
 Now try to ping from one Morning Lab 1(192.168.1.97) to Afternoon Lab 3(192.168.1.39)
   It will Show request timeout.
Try it from Afternoon and Evening Labs.
           If is there any mistakes and for any clarification mail to ccnalab06@gmail.com  .  (ZeroSix)